
DATA CONSOLIDATION AND SUBTOTAL IN LIBREOFFICE CALC 

DATA CONSOLIDATION 

Data consolidation in LibreOffice Calc refers to the process of combining data from 

multiple sheets or ranges into a single location. It allows you to summarize and analyze data 

from different sources conveniently. Here’s how you can perform data consolidation in 

LibreOffice Calc: 

1. Open the document that contains the cell ranges you want to consolidate. 

2. Go to Data in the menu bar and select Consolidate. 

3. In the Consolidate dialog, follow these steps: 

o Choose the source cell range(s) to consolidate with other areas. 

o Specify where you want to display the consolidated result (target range). 

o Select a function (e.g., Sum, Average, and Count) to link the values from different ranges. 

o Optionally, check the options for consolidating by row or column labels and linking to 

source data. 

4. Click OK to consolidate the data. 

SUBTOTAL 

In LibreOffice Calc, the Subtotals feature allows you to calculate subtotals and grand totals 

for data in a labeled range. It’s a powerful tool for summarizing data and creating 

hierarchical structures within your spreadsheet. Let me guide you through how to use it: 

1. Select the Data Range: 

o First, select the cell range that contains the data for which you want to calculate subtotals. 

o Make sure to include the column heading labels. 

2. Access the Subtotals Tool: 

o Go to Data > Subtotals in the menu. 

3. Configure Subtotals: 

o In the Subtotals dialog, you’ll see several options: 

 Group by: Choose a column by its label. Entries in the selected cell range will be grouped 

and sorted by matching values in this column. 

 Calculate subtotals for: Select a column containing values to be subtotaled. 

 Use function: Choose a function (e.g., SUM, AVERAGE) to calculate the subtotals for the 

selected column. 

 You can create multiple subtotal categories by repeating these steps. 

4. Apply and View Results: 

o Click OK to apply the subtotals. 

o Calc will add subtotal and grand total rows to your cell range. 

o An outline will appear to the left of the row number column, representing the hierarchical 

structure of your subtotals. You can use this outline to hide or show data at different levels. 

Remember that the Subtotals tool simplifies the process of calculating subtotals and 

organizing your data. It’s especially useful when dealing with large datasets! 

Practical session 

https://www.youtube.com/watch?v=3h5vJbwX9IM 

https://www.youtube.com/watch?v=3h5vJbwX9IM


 

WHAT-IF ANALYSIS (IN LIBREOFFICE CALC) 

In LibreOffice Calc, the What-If Analysis feature allows you to explore different 

scenarios by changing input values and observing their impact on calculated results. It’s 

a powerful tool for decision-making, sensitivity analysis, and understanding how 

changes affect outcomes. Here are some key aspects of What-If Analysis: 

(i). Scenario 

(ii). Goal seek 

(iii) Solver 

SCENARIO 

In LibreOffice Calc, a scenario is a powerful tool that allows you to explore different 

“what-if” situations by changing input values and observing their impact on calculated 

results. Scenarios are particularly useful for sensitivity analysis, decision-making, and 

understanding how changes affect outcomes. Let’s dive into how to use scenarios: 

1. Creating a Scenario: 

o First, select the cell range that contains the data you want to analyze. 

o Next, choose the cells that contain the values you want to change between scenarios 

(e.g., interest rates, production quantities, discount percentages). 

o Go to Tools > Scenarios. 

o In the Create Scenario dialog, give your scenario a name and leave other fields 

unchanged with their default values. 

o Click OK to create the scenario. 

 

2. Managing Scenarios: 

o You can access scenarios through the Navigator: 

 Open the Navigator using the Navigator icon on the Standard toolbar. 

 Click the Scenarios icon in the Navigator. 

o In the Navigator, you’ll see the defined scenarios along with any comments you added 

during scenario creation. 

o Double-click a scenario name in the Navigator to apply that scenario to the current 

sheet. 

 

3. Editing and Deleting Scenarios: 

o To edit a scenario, right-click the scenario name in the Navigator and 

choose Properties. 

o To delete a scenario, right-click the scenario name in the Navigator and choose Delete. 



 

4. Hiding Scenario Borders: 

o If you want to hide the border of a set of cells that are part of a scenario: 

 Open the Properties dialog for each scenario that affects those cells. 

 Clear the Display border checkbox. 

o Hiding the border also removes the list box on the sheet where you can choose 

scenarios. 

Practical Demo 

https://www.youtube.com/watch?v=Aza-dF619sY 

GOAL SEEK 

o Goal Seek in LibreOffice Calc is a powerful tool that allows you to find the input value 

needed to achieve a specific result in a formula. It’s particularly useful for solving 

equations with a single variable. Here’s how it works: 

o Scenario: 

o Imagine you have a formula that calculates a result based on certain input values (e.g., 

interest rate, investment amount, loan term). 

o You want to know what value of one of the inputs would lead to a desired output. 

o Example: 

o Let’s say you have an investment with an initial amount of $10,000, an annual interest 

rate of 5%, and you want to find out how many years it would take for the investment to 

grow to $15,000. 

o You can use Goal Seek to determine the number of years needed to achieve this target. 

o Steps to Use Goal Seek: 

o Enter the initial investment amount, interest rate, and a formula to calculate the final 

amount. 

o Go to Tools > Goal Seek. 

o In the Goal Seek dialog: 

o Specify the cell containing the formula result (e.g., the final amount). 

o Set the target value (e.g., $15,000). 

o Specify the cell containing the variable you want to adjust (e.g., the number of years). 

o Click OK, and Calc will adjust the number of years to achieve the desired result. 

o Result: 

o Goal Seek will find the value for the number of years that makes the investment grow to 

$15,000. 

o Remember that Goal Seek is a valuable tool for solving equations and exploring 

different scenarios in your calculations 

Practical Demo 

https://www.youtube.com/watch?v=ibUqB7npHp8 

https://www.youtube.com/watch?v=Aza-dF619sY
https://www.youtube.com/watch?v=ibUqB7npHp8


SOLVER 

Solver in LibreOffice Calc is a powerful tool that allows you to solve equations with 

multiple unknown variables by goal-seeking methods. It helps you find the input values 

that result in an optimized value in the target cell (also known as the “objective”). Here’s 

how you can use Solver: 

1. Scenario: 

o Imagine you have a complex equation involving several variables (e.g., production costs, 

resource allocation, project scheduling). 

o You want to find the optimal values for these variables to achieve a specific goal (e.g., 

maximize profit, minimize cost, meet a deadline). 

2. Solver Process: 

o Define the objective (target cell) that you want to optimize (e.g., maximize, minimize, 

reach a specific value). 

o Specify the changing cells (variables) that Solver can adjust to achieve the objective. 

o Set constraints (limits) on certain cells (e.g., budget constraints, resource availability). 

o Run Solver, and it will adjust the variable values to find the optimal solution. 

3. Linear and Nonlinear Equations: 

o Solver can handle both linear and nonlinear equations. 

o Linear equations involve simple addition, subtraction, multiplication, and division. 

o Nonlinear equations may involve more complex functions (e.g., exponential, 

logarithmic). 

4. Example Scenarios: 

o You’re managing a production process with limited resources (e.g., labor, raw materials). 

o You want to maximize production output while staying within budget constraints. 

o Solver can adjust resource allocation to achieve this goal. 

o Remember that Solver is a valuable tool for optimization, decision-making, and finding 

the best solutions to complex problems 

Practical Demo 

https://www.youtube.com/watch?v=bUutZa8ATbM  

SHARING SPREADSHEETS 

Sharing spreadsheets in LibreOffice Calc allows several users to open the same file 

for editing simultaneously. You can collaborate on a spreadsheet by following these 

steps: 

1. Prepare Your Spreadsheet: 

o Make sure your spreadsheet is saved and contains the data you want to share. 

o Save the file in a location accessible by all collaborators (e.g., a shared drive, server, 

website, or similar). 

2. Enable Sharing: 

o Open your spreadsheet in LibreOffice Calc. 

o Go to Tools > Share Document. 

https://www.youtube.com/watch?v=bUutZa8ATbM


o In the resulting window, check the checkbox for Share This Spreadsheet with 

Other Users. 

o Save the document. 

3. Collaborate with Others: 

o Now your spreadsheet is ready for other users to open and edit. 

o Collaborators can access the shared file from the same location where it’s saved. 

o Changes made by one user will be visible to others in real-time. 

Remember that sharing spreadsheets enhances collaboration and allows multiple 

users to work together efficiently 

https://www.youtube.com/watch?v=0t2M7PIplJQ 

 

HYPERLINKS IN LIBREOFFICE CALC 

In LibreOffice Calc, hyperlinks allow you to create clickable links within your 

spreadsheets. These links can point to various destinations, such as other cells in the 

same sheet, external websites, or files. Here’s how you can use hyperlinks in Calc: 

1. Adding a Hyperlink to a Cell: 

o Click on the cell where you want to insert the hyperlink. 

o Go to Insert > Hyperlink or use the keyboard shortcut Ctrl+K. 

o In the Hyperlink dialog: 

 For web URLs or FTP addresses, select “Internet” on the left side. Enter the URL and 

the text you want to display in the cell. 

 For linking to other cells within the same sheet, select “Document” on the left side. 

Specify the target cell address (e.g., G10). 

 Click OK to create the hyperlink. 

o Now, pressing Ctrl+K will follow the hyperlink. 

2. Adding a Hyperlink Using the HYPERLINK Function: 

o You can also use the HYPERLINK() function in your formulas to create hyperlinks 

dynamically. 

o The syntax is: =HYPERLINK(URL, CellText). 

 URL: The clickable URL or address. 

 CellText: The text to display in the cell. 

o For example, to create a hyperlink to a website, use: 
o =HYPERLINK("https://www.example.com", "Visit Example Website") 

 

3. Managing Hyperlinks: 

o To edit or remove a hyperlink, right-click the cell with the hyperlink and choose Edit 

Hyperlink or Remove Hyperlink from the context menu. 

o You can also use the Navigator (Ctrl+F5) to manage hyperlinks in your document. 

Practical Demo 

https://www.youtube.com/watch?v=CSvg6dZOXRk 

https://www.youtube.com/watch?v=0t2M7PIplJQ
https://www.youtube.com/watch?v=CSvg6dZOXRk


Types of Hyperlinks 

1. Absolute Hyperlinks: 
o An absolute hyperlink contains the full address of the target file or website. It 

includes the protocol (e.g., HTTP, HTTPS) and the domain name (e.g., 
www.example.com). 

 

2. Relative Hyperlinks: 
o A relative hyperlink contains an address that is relative to the current domain or file 

location. 
o It assumes that the link you add is on the same site and part of the same root 

domain. 

External Data 

To link external data in LibreOffice Calc, follow these steps: 
1. Choose Sheet - Link to External Data: 
o Go to the sheet where you want to insert the external data. 
o Click on Sheet in the menu bar. 
o Select Link to External Data. 
2. Enter the URL or File Name: 
o In the dialog that appears, enter the URL or the file name that contains the data 

you want to insert. 
o Press Enter. 
o Alternatively, click the Browse button to select the file name from a file dialog that 

opens. Only then will the URL be requested from the network or file system. 
3. Select the Data Range: 
o If you’re linking to an HTML, Calc, CSV, or Excel file, the data must be located 

within a named range. 
o Choose the table or data range you want to insert from the available options. 
4. Update Frequency (Optional): 
o You can specify how often the external data should be reloaded into the current 

document. 
o Enter the number of seconds to wait before the data is updated. 

That’s it! You’ve successfully linked external data in LibreOffice Calc.  

 
  

http://www.example.com/


Linking to Registered data source 

To link data from external sources in LibreOffice Calc, you can follow these steps: 
1. Register the Data Source: 
o First, you need to register the data source with LibreOffice. This means telling 

LibreOffice what type of data source it is and where the file is located. 
o To do this, go to Tools > Options > LibreOffice Calc > Defaults on the menu bar. 
o Specify the URL or file name that contains the data you want to insert, and then 

press Enter. This will prompt LibreOffice to request the URL from the network or 
file system. 

2. Link the Data: 
o Once the data source is registered, you can link it into your Calc document. 
o Choose the sheet where you want to insert the external data. 
o Click on Sheet in the menu bar and select Link to External Data. 
o Enter the URL or file name again, and choose the appropriate data range or table. 
3. Refresh the Data: 
o If the data changes in the external source, you can refresh the linked data range in 

Calc to update it. 

Remember, this process allows you to access a variety of databases and other data 
sources directly within your Calc documents.  

 

SHARE AND REVIEW A SPREADSHEET 

In LibreOffice Calc, sharing sheets allows multiple users to simultaneously edit the 
same spreadsheet. Here’s why you might use it: 

1. Collaboration: Sharing a spreadsheet enables real-time collaboration among team 
members. Everyone can work on the same document simultaneously, making 
updates and changes as needed. 

2. Efficiency: Instead of passing files back and forth, users can directly edit the shared 
document. This streamlines communication and reduces version control issues. 

3. Centralized Access: The spreadsheet resides on a shared drive, server, or website, 
accessible to all collaborators. It ensures everyone works with the latest version. 

4. Locking Design Elements: When a document is shared, formatting and 
chart/drawing editing attributes are locked. Users can alter data but not the 
design. To regain access to design elements, simply unshare the document1. 

In summary, sharing sheets in Calc promotes teamwork, efficiency, and centralized 
access for collaborative work! 

you can share spreadsheets to allow several users to open the same file for editing 
simultaneously. Here’s how: 

1. Register the Data Source: 

https://www.techrepublic.com/article/merge-or-share-your-libreoffice-calc-spreadsheets/


o First, ensure that the spreadsheet is saved in the .ods file format (later, you can 
save it as an .xls file if needed for Microsoft Office compatibility). 

o Go to Tools > Share Spreadsheet. 
o The spreadsheet should be stored on a shared drive, server, website, or similar 

location accessible to all collaborators. 
2. User Permissions: 
o Set file permissions for both the document and the corresponding lock file so that 

all collaborators can create, delete, and modify files. 
o Each collaborator should enter their name in Tools > Options > LibreOffice > User 

Data to correctly identify changes. 
3. Collaborate away 

Removing a spreadsheet from being shared 

To remove a sheet from being shared in LibreOffice Calc, follow these steps: 
1. Switch to Unshared Mode: 
o Open the shared spreadsheet in Calc. 
o Go to Tools > Share Spreadsheet on the menu bar. 
o Click on it to switch the spreadsheet from shared to unshared mode. 
o Note that once you do this, other users will no longer be able to edit it. 

COMMENT in a Worksheet 

In LibreOffice Calc, a comment is a way to attach additional information or notes to 
a specific cell within a spreadsheet. Here are the key points about comments: 

1. Adding Comments: 
o You can assign a comment to any cell by choosing Insert > Comment. 
o When you do this, a small red square (the comment indicator) appears in the cell. 
o The comment becomes visible when you hover the mouse pointer over the cell. 
o If you select the cell, you can choose “Show Comment” from the context menu to 

display the comment. 
2. Purpose of Comments: 
o Comments allow you to provide explanations, context, or other helpful insights 

related to the data in a cell. 
o Reviewers and authors can add their own comments to explain changes made or 

share additional information. 

Remember, comments enhance collaboration and understanding within your 
spreadsheet!  

3. Edit Comment: 

To edit a comment in LibreOffice Calc, follow these steps: 
a). Show the Comment: 



o Right-click on the cell containing the comment. 
o Select “Show Comment” from the context menu. 
o The comment will become visible. 

 

b). Edit the Comment: 

o Right-click again on the cell with the visible comment. 
o Choose “Edit Comment” from the context menu. 
o You can now modify the comment text as needed. 

Remember, comments provide additional context and explanations within your 
spreadsheet!  

4. Delete Comment 

To delete a comment in LibreOffice Calc, follow these steps: 

1. Right-click the cell containing the comment. 
2. Choose Delete Comment from the context menu. 

That’s it! The comment will be removed from the cell. 

5. Show or Hide Comment 

a). Click on the cell containing the comment 

b). Click on the sheet menu-> cell comments-> Show /Hide comment 

OR 

Right Click on the cell and select the show/Hide comment option from the shortcut 
menu 

c). The comment will remain remain on display for the cell. 

4). To hide the comment, click on the show/hide comment option again. 

TRACK CHANGES 

The Track Changes feature in LibreOffice Calc allows you to record, view, edit, 
accept, or reject changes made by others in a shared spreadsheet. When enabled, 
new text passages are underlined in color, while deleted text remains visible but is 
crossed out and shown in color. To use it: 

1. Open your spreadsheet in LibreOffice Calc. 
2. Go to Edit → Track Changes → Record. 
3. Start making changes; they’ll be marked with underlines or strikethroughs. 
4. Review and manage changes using the Track Changes toolbar or dialog box 



To Turn Off Recording 

To stop recording changes in LibreOffice Calc, follow these steps: 

1. Choose Edit → Track Changes → Record again. 
2. The check mark will be removed, and you can now save the document 

Compare and Review/Manage changes 

To compare and review changes in LibreOffice Calc, follow these steps: 

1. Open the newer version of your spreadsheet document. 
2. Go to Edit → Track Changes → Compare Document. 
3. A file selection dialog will appear. Choose the older original document you want to 

compare with. 
4. Confirm the dialog, and LibreOffice will display the changes between the two 

versions. 

You can then navigate through the changes, accept or reject them 

Practical Demo 

TRACK CHANGES in LibreOffice Calc (youtube.com) 

 

MERGE WORKSHEETS 

To merge worksheets in LibreOffice Calc, follow these steps: 

1. Open the primary document containing the sheets you want to merge. 
2. Right-click on the second sheet’s tab and select “Duplicate sheet” from the menu. 
3. Right-click on the letter A (the header of the first column) in the duplicated sheet 

and choose “Insert columns after”. 
4. Jump to the end of the data in the duplicated sheet. 
5. Switch back to the first sheet, select the data using Ctrl+* or go 

to Edit → Select → Select data area. 
6. Copy the selected data. 
7. Return to the duplicated sheet and paste the data there 

Accept or Reject Changes 

To accept or reject changes in LibreOffice Calc, follow these steps: 

1. Open the document containing the changes. 
2. Go to Edit → Track Changes → Manage. 
3. In the Manage Changes dialog, select a change from the list. 

https://www.youtube.com/watch?v=8uIwmm0W0tw


4. Review the change displayed in the document. 
5. Use the buttons to accept or reject the change 

 

 

MACROS IN SPREADSHEET 

A macro in LibreOffice Calc is a set of recorded actions that can be replayed to 
automate repetitive tasks. It allows users to perform complex operations with a 
single click, saving time and effort. Macros are especially useful when you need to 
repeat the same task in the same way over and over again. You can create macros 
by recording actions through LibreOffice’s user interface or by writing code using 
one of the supported scripting languages 

Enabling Macro in Calc 

To enable macros for LibreOffice Calc, follow these steps: 

1. Go to Tools → Options → LibreOffice → Advanced on the menu bar. 
2. Select the Enable macro recording 
3. Click Ok 

Practical Demo  (Enabling Macro) 

LibreOffice Calc Macro (youtube.com) 

 

Record Macros 
To record a macro in LibreOffice Calc, follow these steps: 

1. Open your spreadsheet document in LibreOffice Calc. 
2. Go to Tools → Macros → Record Macro on the menu bar. 
3. If the Record Macro menu item is missing, ensure that macro recording is enabled 

in Tools → Options → LibreOffice → Advanced. 
4. A small dialog with a single button called Stop Recording will appear. 
5. Perform the actions you want to record within the document (e.g., typing data, 

formatting cells, or applying formulas). 
6. Press the Escape key to deselect an object (note that mouse clicks for deselection 

are not recorded). 
7. Click Stop Recording when you’re done. 
8. The Macro dialog will appear, allowing you to save and run the recorded macro. 

 

https://www.youtube.com/watch?v=_Y3REMbwg-U


Practical Demo 

Recording a Macro and Adding a Button in LibreOffice 4 (youtube.com) 

Run Macros 

To run a recorded macro in LibreOffice Calc, follow these steps: 

1. Open your spreadsheet document in LibreOffice Calc. 
2. Go to Tools → Macros → Run Macro. 
3. In the Macros dialog box, select the macro you want to run. 
4. Click on Run. 

Delete a recorded macro 

To delete a macro in LibreOffice Calc, follow these steps: 

1. Open your spreadsheet document. 
2. Go to Tools → Macros → Organize Macros → LibreOffice Basic. 
3. In the Organizer dialog, select the library containing the macro you want to delete. 
4. Choose the macro from the list and click Delete 

 

Creating A Simple Macro Using Programming Language 

We can customize macros in calc using different programming language like Basic, 
Shell, Java or Python programming language. We here use Basic language.  

Let us create a simple macro in the same spreadsheet, i.e. MACRO_1, .ods to 
display the output in the message box. 

1. Open the spreadsheet MACRO_1.ods. 

2. Click on the Tools → Organize Macros LibreOffice Basic Macros. To open the 
LibreOffice Basic Macros dialog box. 

3. Click on the MACRO_1.ods to expand MyMacroLibrary → Modulel. 

4. Click in the Macro Name box to type the name of the macro as FirstMacro. 

5. Now, click on the New button; it will open the LibreOffice Basic window. Here, 
you will be able to see the automatic coding of the macro earlier recorded by us. 

6. The cursor would blink at the beginning of the new macro created by us with the 
start and end line of a procedure, as shown in the figure. 

https://www.youtube.com/watch?v=EAm7RgzWRhM


7. Place the cursor to the next line of the start of the procedure and type Print "In 
this way, we can create a simple macro" as shown in the figure. 

8. Save the macro by clicking on the Save icon  

9. Click on the Run menu -> Run command to check the functionality of the macro 
in Libreoffice Basic window. A Warning message box will appear as the output of 
the macro created by us. 

 

Macro as a Function  

Consider a situation wherein you need to perform calculations that are repetitive 
in nature. Assume that the same formula needs to be applied to different data in 
different sheets and there is no predefined function for it. In such a situation will it 
not be convenient if we could create a macro that performs the calculations? It will 
save us the effort of remembering and typing the formulas. It is possible to do so if 
we use Macro as a function. Instead of writing instructions in between Sub and End 
Sub, we can write instructions in between Function and End Function. A function is 
capable of accepting arguments or values. It can perform operations on the 
arguments, perform calculations and return the result. 


